Creating Sitemap: clicking "Build Now" prompts "pling" sound and nor result

  • 8 Replies
  • 1894 Views
*

neomagic

  • Newbie
  • *
  • 4
  • +0/-0
    • View Profile
After crawling the site if I click "build now" it will just make a sound and and switch to "View files" tab. What gives?

*

Webhelpforums

  • Administrator
  • Hero Member
  • *****
  • 1386
  • +6/-0
  • Shared between Microsys, WebHelpForums and helpers
    • View Profile
    • Webmaster and Website Help Forums
Assuming default settings. What do you see after website crawl finishes? (Before creating sitemaps)

If for instance your website uses noindex, nofollow, robots.txt to block all URLs, there will be no pages included in sitemap (or viewable after crawl) since A1 Sitemap Geneator defaults to obey those things:

http://www.microsystools.com/products/sitemap-generator/help/sitemap-robots-noindex-nofollow/



If that does not solve your problem:

What version are you using? And what is the website address? If you prefer you can also email support directly with your website address at:

http://www.microsystools.com/home/contact.php
MicrosysTools.com | Website and SEO Software for webmasters | A1 Sitemap Generator, A1 Website Analyzer etc.

*

neomagic

  • Newbie
  • *
  • 4
  • +0/-0
    • View Profile
Thank you for your reply. I am using the current program version with default settings adding only my domain name http://tupower.eu. The crawl finished successfully after many hours. The results look good. I also get to save them. Only the conversion to a sitemap won't work.

*

Webhelpforums

  • Administrator
  • Hero Member
  • *****
  • 1386
  • +6/-0
  • Shared between Microsys, WebHelpForums and helpers
    • View Profile
    • Webmaster and Website Help Forums
Are you using "Build" or "Build all"

Have you tried checking the dropdown box to see if you can select to view another sitemap file?


Could it be a file access problem? i.e. if A1SG is prevented creating files in the selected directory?

http://www.microsystools.com/products/sitemap-generator/help/sitemap-creator-storage-path/
http://www.microsystools.com/products/sitemap-generator/help/site-map-generator-program-file-write/

(should not be a problem is using defaults)
MicrosysTools.com | Website and SEO Software for webmasters | A1 Sitemap Generator, A1 Website Analyzer etc.

*

neomagic

  • Newbie
  • *
  • 4
  • +0/-0
    • View Profile
Here's the crawling result: https://docs.google.com/open?id=0B1ZRYNlgr3jySE1RNG03d3ZsUDQ





Other sitemap=same problem: I click "Rebuild"--> pling sound-->switches to "View files"

*

Webhelpforums

  • Administrator
  • Hero Member
  • *****
  • 1386
  • +6/-0
  • Shared between Microsys, WebHelpForums and helpers
    • View Profile
    • Webmaster and Website Help Forums
All your pages seem to contain

Code: [Select]
<link rel="canonical" href="http://www.tupower.de" />
Since A1SG considers that a redirect then...
MicrosysTools.com | Website and SEO Software for webmasters | A1 Sitemap Generator, A1 Website Analyzer etc.

*

neomagic

  • Newbie
  • *
  • 4
  • +0/-0
    • View Profile
I'm sorry, I don't understand your reply with regards to what course of action I can take.  :-\

*

Webhelpforums

  • Administrator
  • Hero Member
  • *****
  • 1386
  • +6/-0
  • Shared between Microsys, WebHelpForums and helpers
    • View Profile
    • Webmaster and Website Help Forums
I will return with a better explanation later today. Just need to confirm what I wrote was indeed the reason :)

Under all circumstances, it is not an advantage for you that all your pages point to a single page on another domain using the canonical tag. (Just see the HTML source and your use of the canonical tag.)
MicrosysTools.com | Website and SEO Software for webmasters | A1 Sitemap Generator, A1 Website Analyzer etc.

*

Webhelpforums

  • Administrator
  • Hero Member
  • *****
  • 1386
  • +6/-0
  • Shared between Microsys, WebHelpForums and helpers
    • View Profile
    • Webmaster and Website Help Forums
Okay, just confirmed that my reasoning yesterday appears to be correct :)


That is desired *default* behavior by A1SG as your pages explicitly tell crawlers that they are not the favored/canonical URL. (This is also used when building the sitemaps.) It would actually be a bug if A1SG included a page URL in XML sitemaps that refers to another using canonical instruction. (Assuming the scan and analysis was fully completed before building the XML sitemap.)


However, if you for some reason can not / do not want to change that, you can always ask A1 Sitemap Generator to ignore the canonical instruction :)

First switch off "Easy mode":
http://www.microsystools.com/products/sitemap-generator/help/easy-sitemap-generator-mode/

Then switch off support for "canonical":
http://www.microsystools.com/products/sitemap-generator/help/sitemap-robots-noindex-nofollow/


Hope that solves your problems :)

You may also be interested in reading about:
http://www.microsystools.com/products/sitemap-generator/help/duplicate-content-page-urls/
« Last Edit: August 15, 2012, 09:42:22 AM by Webhelpforums »
MicrosysTools.com | Website and SEO Software for webmasters | A1 Sitemap Generator, A1 Website Analyzer etc.

 




See Our Webmaster Tools for Windows and Mac

A1 Sitemap Generator
      
A1 Website Analyzer
      
A1 Keyword Research
      
A1 Website Download
      
A1 Website Search Engine
      
A1 Website Scraper