FTP Connection Failure

  • 6 Replies
  • 3072 Views
*

thallstd

  • Newbie
  • *
  • 7
  • +0/-0
    • View Profile
FTP Connection Failure
« on: September 04, 2012, 01:02:56 PM »
Initially my FTP connection was working fine but in troubleshooting another issue I made some changes to crawling settings.  At some point after that the upload of the sitemap began failing on the ftp connection:

FTP: allaboutdogbehavior.com:21
Connecting...
Connection failed...

I have it configured identically to FileZilla which can connect fine. 

Any idea what I should look at?

Thanks

BTW - love the product.  I've been a software developer since '76 and appreciate how much you have put into this.  I've barely scratched the surface so far...

*

Webhelpforums

  • Administrator
  • Hero Member
  • *****
  • 1414
  • +6/-0
  • Shared between Microsys, WebHelpForums and helpers
    • View Profile
    • Webmaster and Website Help Forums
Re: FTP Connection Failure
« Reply #1 on: September 04, 2012, 07:33:53 PM »
Offhand crawler settings and FTP settings should not affect each other.

Have you tried re-enter all FTP information including things like password?
(The password is stored in a way, so if you change computer/network, it will not be read correctly any longer.)

You can also check the FTP help page:
http://www.microsystools.com/products/sitemap-generator/help/sitemap-generator-ftp-upload/

Could it be a firewall issue?
http://www.microsystools.com/products/sitemap-generator/help/site-map-creator-firewall/

Does the problem exist with other websites as well?

If the problem persist, and you can share access, email us directly, so we can try:
http://www.microsystools.com/home/contact.php


Thanks for the nice words about the software, it is appreciated :)
TechSEO360 | MicrosysTools.com  | A1 Sitemap Generator, A1 Website Analyzer etc.

*

thallstd

  • Newbie
  • *
  • 7
  • +0/-0
    • View Profile
Re: FTP Connection Failure
« Reply #2 on: September 05, 2012, 11:30:44 AM »
Thanks for the tips.

I have re-entered all info and established a separate ftp account for testing that also fails. 

I use McAfee and according to it the firewall is off so I don't think that's related.

I have tried with 2 different sites and 3 different connections and they all fail instantly in A1SG but work in Filezilla.

Also, I don't know if it's related or not but Pinging is also failing.  And I get a consistent -12 (rcCommErrorChunkedWrong) when scanning my site.

Other than the login/connection info I don't see any settings for ftp.

So I decided to reboot and lo and behold everything now works.  I do see some things I can't explain in the scan results but will start a separate thread for that.

*

Webhelpforums

  • Administrator
  • Hero Member
  • *****
  • 1414
  • +6/-0
  • Shared between Microsys, WebHelpForums and helpers
    • View Profile
    • Webmaster and Website Help Forums
Re: FTP Connection Failure
« Reply #3 on: September 05, 2012, 11:51:10 AM »
If a reboot worked then... I am a little baffled as well :)

You don't have any other software/hardware packet inspection/filtering on your network? Anyhow, good to hear the problem has resolved itself.

Regarding A1SG and HTTP response codes, check this help page:
http://www.microsystools.com/products/sitemap-generator/help/server-http-response-codes/
« Last Edit: September 05, 2012, 11:54:20 AM by Webhelpforums »
TechSEO360 | MicrosysTools.com  | A1 Sitemap Generator, A1 Website Analyzer etc.

*

thallstd

  • Newbie
  • *
  • 7
  • +0/-0
    • View Profile
Re: FTP Connection Failure
« Reply #4 on: September 05, 2012, 01:09:48 PM »
I did just rescan to check some other issues, all of which I have explained or resolved but one that I'll open another thread for.

However, after scanning I again couldn't ftp.  This time I was able to just relaunch A1SG to correct the problem.  Something weird is still going on but as long as I can easily get around it I suppose we both have better things to do...

*

Webhelpforums

  • Administrator
  • Hero Member
  • *****
  • 1414
  • +6/-0
  • Shared between Microsys, WebHelpForums and helpers
    • View Profile
    • Webmaster and Website Help Forums
Re: FTP Connection Failure
« Reply #5 on: September 05, 2012, 02:17:22 PM »
If you can duplicate a set of steps that causes problem, please email details (project file, login if possible etc.) to:
http://www.microsystools.com/home/contact.php

Will try make a note of it as well, but from your description, I am almost sure it will be hard to reproduce without steps.
TechSEO360 | MicrosysTools.com  | A1 Sitemap Generator, A1 Website Analyzer etc.

*

thallstd

  • Newbie
  • *
  • 7
  • +0/-0
    • View Profile
Re: FTP Connection Failure
« Reply #6 on: September 05, 2012, 02:54:18 PM »
Just went through the same steps again to test your solution to the -12 errors and the ftp problem didn't reproduce.  So I don't have fixed steps that create the problem.  I will keep an eye on it and if I find a correlation to anything will let you know.

 




See Our Webmaster Tools for Windows and Mac

A1 Sitemap Generator
      
A1 Website Analyzer
      
A1 Keyword Research
      
A1 Website Download
      
A1 Website Search Engine
      
A1 Website Scraper