Shortcuts Lost When Saving

  • 19 Replies
  • 4377 Views
*

rah

  • Newbie
  • *
  • 6
  • +0/-0
    • View Profile
Shortcuts Lost When Saving
« on: May 29, 2012, 01:01:47 PM »
I'm using v1.9.9 Pro on Windows 7 Pro SP1.

Since updating to this version, I've tried a couple of times to modify my shortcuts and then save them. Each time all my shortcuts were deleted and I was left with 2 entries that looked like defaults that you'd see when you initially install Launcher.

I was able to restore my shortcuts from a backup but I tried modifying it again and the same thing happened.

My shortcuts are saved to "My Documents" which is a network location. Prior to this version, I've never had this problem.

Normally, Launcher is loaded with windows and that works fine. However, the only way I've been able to save Launcher after modifying it was to manually starting Launcher and running it as an administrator. Then I could successfully save without wiping out my shortcuts.

Is there something I should change in my configuration?

*

Webhelpforums

  • Administrator
  • Hero Member
  • *****
  • 1387
  • +6/-0
  • Shared between Microsys, WebHelpForums and helpers
    • View Profile
    • Webmaster and Website Help Forums
Re: Shortcuts Lost When Saving
« Reply #1 on: May 29, 2012, 05:24:39 PM »
Are you using the latest version 1.9.9 (you probably are if you downloaded it recently, e.g. within last month.)

It is a bit odd because there has gone a long time where I have had no reports of problems, so I was quite sure 1.9.9 was now correctly handling just about any situation, at least 1.9.9 #update 1

...

Just to understand you correctly:

Have you configured Windows to map "My Documents" to a network location?
Or
Have you tried to override settings in file "muc.ini" located in Launcher directory ?

...

You don't get any errors from Launcher when trying to save?

...

Launcher (in its newest incarnation) tests it can save/delete/rename/read/write/etc. files before it even tries to save/delete shortcuts.  I implemented that to avoid saving if any Windows access rights problems were likely to happen. You should get an error if any of the tests fail... From your description, you don't get any?

It sounds like you need to run Launcher as an administrator which makes kinda sense, but I don't quite understand why your old shortcuts disappear (since delete/create files usually requires the same access rights.)

...

Notice that since you use 1.9.9 you can now backup directly from within Launcher when saving. (But there could be file access problems there as well, but if so, the saving process should abort)

When clicking the "Save" button in "Manage items" a menu opens which contains an "options" menu item.

« Last Edit: June 14, 2012, 04:44:55 PM by Webhelpforums »
MicrosysTools.com | Website and SEO Software for webmasters | A1 Sitemap Generator, A1 Website Analyzer etc.

*

Webhelpforums

  • Administrator
  • Hero Member
  • *****
  • 1387
  • +6/-0
  • Shared between Microsys, WebHelpForums and helpers
    • View Profile
    • Webmaster and Website Help Forums
Re: Shortcuts Lost When Saving
« Reply #2 on: June 14, 2012, 04:45:00 PM »
Update 2012-06-14

It is possible that Windows redirects writes when you don't run in administrator mode + trying to save/write shortcuts to a networked path.

(Although Launcher does above described tests to try make sure read/writes happens in the same actual directory.)

If Launcher does not have credentials to the networked drive, it is possible Windows redirects the writes silently which I know Windows can/will do under some circumstances.

But it should never be a problem when using e.g. the default locations...
Except of course if the Windows is configured in some odd way.

Even if Windows is infact redirecting file writes, the behavior you describe still seems a bit odd to me.

MicrosysTools.com | Website and SEO Software for webmasters | A1 Sitemap Generator, A1 Website Analyzer etc.

*

Via Cassian

  • Newbie
  • *
  • 8
  • +0/-0
    • View Profile
Re: Shortcuts Lost When Saving
« Reply #3 on: December 18, 2012, 02:53:40 PM »
I have 1.9.9 on Win 7 64.

In the past couple of months I have lost most and today I lost all of my shortcuts (except the one I was adding) when saving after adding a new shortcut.

I have backups of my shortcuts.

My questions are:  How do I restore the backup?  What folder do I use, where do I put the backup, what do I name it?  I know where the backups are stored, it was not clear how I would do the restore.

Thank you.

John

*

Webhelpforums

  • Administrator
  • Hero Member
  • *****
  • 1387
  • +6/-0
  • Shared between Microsys, WebHelpForums and helpers
    • View Profile
    • Webmaster and Website Help Forums
Re: Shortcuts Lost When Saving
« Reply #4 on: December 19, 2012, 10:11:11 AM »
Sorry to hear of the problems.

I guess I in version 2.x will have to try opt for a single-file-storage when saving/loading shortcuts.
(Should anyone ever find a way to reproduce the problem in 1.9.9 do let me know.)
Should I implement that for 2.x, I will of course do so it can still read 1.x shortcuts.

...

To find backups:

1)
Find out where you store the normal "shortcuts" folder:
http://www.microsystools.com/products/launcher/help/locate-launcher-installation/

2)
Open the Application user data directory

3)
Exit Launcher.

4)
In there you can see a directory called shortcuts as well as backup directory called something similar to: shortcuts_backup_2012-12-19 16_09_49

5)
Simply rename/remove your old shortcuts directory and copy shortcuts_backup_2012-12-19 16_09_49 (or whatever it is called) into as new shortcuts directory.

6)
Start Launcher

...

Remember that to make shortcut backups, you have to each time check the backup option before saving.
« Last Edit: December 19, 2012, 10:17:33 AM by Webhelpforums »
MicrosysTools.com | Website and SEO Software for webmasters | A1 Sitemap Generator, A1 Website Analyzer etc.

*

Via Cassian

  • Newbie
  • *
  • 8
  • +0/-0
    • View Profile
Re: Shortcuts Lost When Saving
« Reply #5 on: December 19, 2012, 01:17:57 PM »
Thank you, your instructions were easy to follow and worked perfectly.  I am back to working efficiently.

Regarding your comment and question.

I am not sure I understand that you will “try opt for a single-file-storage when saving/loading shortcuts.”  The general method you described to restore is similar to other specialized applications I have — thus, I fully expected to do exactly what you described — get the right files and copy them where they needed to go. 

As to the duplication of the problem, here is what I was trying to do: I added a Directory on disk, Saved it (without having clicked on the Auto Backup — because I had Auto Saved about 20 minutes earlier in the day) and then realized that the Directory was listed by itself at the top of the Launcher list.  I wanted to put the Directory in an existing Menu Folder, so I dragged and dropped the Directory into the “Top” portion of an existing Menu Folder and then when I clicked Save (again without Auto Save), all the previous shortcuts disappeared and the only item in Launcher was the Director I had added and tried to move. All other shortcuts and all Menu Folders were gone.  But I have done the exact same things many many times. 

The only other fact that may be helpful is that I use Launcher constantly, probably every 10 minutes or so. Mostly it is to access Directories and Files, and I add or delete about 4 items per day - Directories mostly and maybe a File. Currently I have 40 Directories and 4 Files. About 35 of those 40 Directories are in 6 Menu Folders and 5 of the Directories are outside of a Menu Folder.

And I have several specialized programs that are always open at the same time as Launcher.  And I  often have several other programs like MS Word, Adobe Acrobat, Corel WordPerfect, and Firefox open at the same time.  A software conflict may be the cause — but then I always use the same programs.

I have two 27" monitors and when the Launcher Manage Items window opens, it is set to fill 50% of one of the monitors, so I have lots of real estate to distinguish the Save button on the left from the Delete button on the right, or any of the other buttons. 
   
I am very happy with Launcher.  I use it constantly and being without it disrupts my work because all other ways to navigate to a Folder or File are less efficient — but you know that already!

Thanks again for the instructions and a great product.

John
Tampa, Florida

*

Webhelpforums

  • Administrator
  • Hero Member
  • *****
  • 1387
  • +6/-0
  • Shared between Microsys, WebHelpForums and helpers
    • View Profile
    • Webmaster and Website Help Forums
Re: Shortcuts Lost When Saving
« Reply #6 on: December 28, 2012, 01:14:05 PM »
Thanks for the description. I will try see if I can duplicate it.


One more question regarding the shortcuts problem:

What does the error log say? (Visible from the About | Logs" tab)

MicrosysTools.com | Website and SEO Software for webmasters | A1 Sitemap Generator, A1 Website Analyzer etc.

*

Webhelpforums

  • Administrator
  • Hero Member
  • *****
  • 1387
  • +6/-0
  • Shared between Microsys, WebHelpForums and helpers
    • View Profile
    • Webmaster and Website Help Forums
Re: Shortcuts Lost When Saving
« Reply #7 on: December 30, 2012, 11:41:48 PM »
I have one more question:

Did you try to exit Launcher (exit from system tray as well) to see if the (new and saved) shortcuts would load and show correctly on next startup.

(These questions will help me try pinpoint where in code problem could be.)


MicrosysTools.com | Website and SEO Software for webmasters | A1 Sitemap Generator, A1 Website Analyzer etc.

*

Via Cassian

  • Newbie
  • *
  • 8
  • +0/-0
    • View Profile
Re: Shortcuts Lost When Saving
« Reply #8 on: January 07, 2013, 02:12:59 PM »
Here are answers to your questions.

Question: What does the error log say?

Answer: There is never any error message in the log.  I checked periodically in the steps below.

Question: Did you try to exit Launcher (exit from system tray as well) to see if the (new and saved) shortcuts would load and show correctly on next startup. 

Answer: Yes, but that action did not reload the shortcuts.  I looked at the shortcut file and it is does not contain the full number of entries.

Sorry, to take so long to post again.  I read your questions and started to reply with the answers and then I got the bright idea of trying to duplicate the problem. The last time the problem appeared I was dragging and drop a new Directory on Disk to a Menu Folder.  So since then I had been careful not to drag and drop a new Directory on Disk to a Menu Folder. But with some time on my hands I decided to see if the problem could be duplicated. I have Win 7 64 and Launcher 1.9.9 Pro.

1.  I added a new Directory on Disk (without adding it to a Menu Folder) and then before saving,  I dragged and dropped that Directory on Disk into a Menu Folder that had 17 other Directories on Disk and two Files.  Then I clicked Auto Save and then Save. When I clicked Save, the Windows 7 spinning hourglass appeared for about 1 second, and then all Menu Folders and their contents disappeared and I think several of the Directories on Disk that were not in Menu Folders also disappeared. The Directory on Disk and the Menu Folder into which I was moving the Directory on Disk disappeared.  All Menu Folders were gone.

2. Next, restored my latest backup by doing the following: I deleted the “shortcuts” folder, and renamed my last good backup and then copied it to the Launcher folder so I had a new good shortcuts folder.

3. Next, I repeated the test backup restoration from the same good backup file and duplication of the problem and again all Menu folders and most Directories on Disk that were not in a Menu Folder  disappeared.  I repeated this 5 times, each time with the same result.

4. Next, and again after restoring the same good backup file I changed the test to try to drag and drop the Directory on Disk to another Menu Folder.  Same problem.

5. Next, and again after restoring the same good backup file I changed the test only try to add a Directory on Disk (outside of a Menu Folder).  Same problem.

6. Next, and again after restoring the same good backup file I changed the test by trying to only add a Menu Folder.  Same problem.

7. Next, and again after restoring the same good backup file I changed the test by trying to only save without adding anything — just open Launcher, go to Manage Items, click Auto Save and then Save.  Same problem.

8. By this time, I was thinking there might be some problem with that “good backup to the shortcut” file, so I used the next oldest good backup, but only tried to add a Directory on Disk — same problem.

9. Next, I successfully added a Menu Folder and saved, and then added a second Menu Folder and saved.  Then I successfully added a Directory on Disk and then successfully added a Directory on Disk to a Menu Folder. But I did not try dragging and dropping a new unsaved Directory on Disk to an existing Menu Folder which seemed to be the trigger for the problem.

10. As soon as I was able to successfully add Directories and Menu Folders, when I clicked Auto Save and then Save, the Windows 7 spinning circle hourglass never appeared — ie, saving was so quick, there was no time for the hour glass to appear.  The hour glass appeared each time after clicking save when I lost shortcuts.

11. By this time I was thinking it might be good to uninstall Launcher 1.9.9 and reinstall it.  I downloaded and installed Launcher 2.0 Pro.  When I opened Launcher, it contained the few old shortcuts that remained after the problem and the new Directories on Disk and Menu Folders that I was able to add in step 9. I have been adding shortcuts without any problem since then.

12. I have not tried step 1 again.

Hope that helps.

Again, I use Launcher constantly and think it is the best launcher software available. 

John
Riverview, Florida

*

Webhelpforums

  • Administrator
  • Hero Member
  • *****
  • 1387
  • +6/-0
  • Shared between Microsys, WebHelpForums and helpers
    • View Profile
    • Webmaster and Website Help Forums
Re: Shortcuts Lost When Saving
« Reply #9 on: January 08, 2013, 10:59:10 AM »
Thanks for your description. Will try run a new test later today :)
MicrosysTools.com | Website and SEO Software for webmasters | A1 Sitemap Generator, A1 Website Analyzer etc.

*

tKhomas

  • Newbie
  • *
  • 3
  • +0/-0
    • View Profile
Re: Shortcuts Lost When Saving
« Reply #10 on: February 12, 2013, 06:41:36 PM »
Wow. I also just lost nearly all my shortcuts when saving. I have launcher 2.0.0. I wanted to add another shortcut. I have some troubles adding with drag&drop from time to time (couldn't find out a reason for that) so this time i added the shortcut using "File on disk/lan". When i saved, all my menu folders were lost, and the shortcuts left were the content of one of those folders (a subfolder, to be precise). Of the shortcuts in that folder, only one was missing too, oddly. I managed to get some of my shortcuts back using an undelete program, i learned about the automatic backup feature in this thread now.. would have been great to have, i will use that for sure now..

Hope you can find out about that problem and fix it :)
edit: program.log didn't show anything.

regards,
Thomas

*

Via Cassian

  • Newbie
  • *
  • 8
  • +0/-0
    • View Profile
Re: Shortcuts Lost When Saving
« Reply #11 on: February 13, 2013, 11:32:55 PM »
Yes, it happened again.

I have Windows 7 Pro 64 (build 7601 Service Pack 1).  Now using Launcher 2.0

On January 7, 2012, when I last posted after having a problem with Launcher 1.9,  I installed Launcher 2.0.0. Pro and since installation of 2.0 I have not had any problems until tonight.  I added shortcuts just about every weekday and Launcher hummed away without difficulty.  I did all the things that seemed to trigger loss of shortcuts upon saving when I used 1.9.  For example, I moved menu folders and Dir on disk.  But until tonight I had no problem. 

Tonight, I opened Launcher 2.0 and immediately I (without adding any shortcuts):

Clicked Manage Items
Clicked SAVE
Clicked Options
Clicked Auto Shortcut Backup
Clicked SAVE

Upon clicking Save I lost all shortcuts except the menu folder at the bottom of the list.

I restored an earlier backup, repeated the above and did not lose any shortcuts. 

I made a backup copy of the shortcuts file after I lost virtually all shortcuts except that one menu folder.  If you want to see those files I will email them to you.

In the past when I lost shortcuts, there never was any error messages in the logs and tonight I forgot to check the error log before restoring the backup shortcuts, but I just checked the logs and it contains the following:

--Exception--
DateTime (ISO): 2013-01-12 11:12:41
DateTime (native): 1/12/2013 11:12:41 AM
Sender Class Name: TApplication
Sender Name:
Current Work Directory: C:\Windows\system32
Exception Class Name: EAccessViolation
Exception Message: Access violation at address 0000000000647700 in module 'Launcher.exe'. Read of address 0000000000000018

--Exception--
DateTime (ISO): 2013-01-12 11:12:41
DateTime (native): 1/12/2013 11:12:41 AM
Sender Class Name: TApplication
Sender Name:
Current Work Directory: C:\Windows\system32
Exception Class Name: EAccessViolation
Exception Message: Access violation at address 0000000000647700 in module 'Launcher.exe'. Read of address 0000000000000018

--Exception--
DateTime (ISO): 2013-01-12 11:12:41
DateTime (native): 1/12/2013 11:12:41 AM
Sender Class Name: TApplication
Sender Name:
Current Work Directory: C:\Windows\system32
Exception Class Name: EAccessViolation
Exception Message: Access violation at address 0000000000647700 in module 'Launcher.exe'. Read of address 0000000000000018

--Exception--
DateTime (ISO): 2013-01-14 16:34:37
DateTime (native): 1/14/2013 4:34:37 PM
Sender Class Name: TApplication
Sender Name:
Current Work Directory: C:\Windows\system32
Exception Class Name: EAccessViolation
Exception Message: Access violation at address 0000000000647700 in module 'Launcher.exe'. Read of address 0000000000000018

--Exception--
DateTime (ISO): 2013-01-28 09:47:40
DateTime (native): 1/28/2013 9:47:40 AM
Sender Class Name: TApplication
Sender Name:
Current Work Directory: C:\Windows\system32
Exception Class Name: EAccessViolation
Exception Message: Access violation at address 0000000000647700 in module 'Launcher.exe'. Read of address 0000000000000018

--Exception--
DateTime (ISO): 2013-01-28 09:47:40
DateTime (native): 1/28/2013 9:47:40 AM
Sender Class Name: TApplication
Sender Name:
Current Work Directory: C:\Windows\system32
Exception Class Name: EAccessViolation
Exception Message: Access violation at address 0000000000647700 in module 'Launcher.exe'. Read of address 0000000000000018

--Exception--
DateTime (ISO): 2013-01-28 09:47:40
DateTime (native): 1/28/2013 9:47:40 AM
Sender Class Name: TApplication
Sender Name:
Current Work Directory: C:\Windows\system32
Exception Class Name: EAccessViolation
Exception Message: Access violation at address 0000000000647700 in module 'Launcher.exe'. Read of address 0000000000000018

--Exception--
DateTime (ISO): 2013-01-29 14:42:51
DateTime (native): 1/29/2013 2:42:51 PM
Sender Class Name: TApplication
Sender Name:
Current Work Directory: C:\Windows\system32
Exception Class Name: EAccessViolation
Exception Message: Access violation at address 0000000000647700 in module 'Launcher.exe'. Read of address 0000000000000018

--Exception--
DateTime (ISO): 2013-01-29 14:42:51
DateTime (native): 1/29/2013 2:42:51 PM
Sender Class Name: TApplication
Sender Name:
Current Work Directory: C:\Windows\system32
Exception Class Name: EAccessViolation
Exception Message: Access violation at address 0000000000647700 in module 'Launcher.exe'. Read of address 0000000000000018

--Exception--
DateTime (ISO): 2013-01-29 14:42:51
DateTime (native): 1/29/2013 2:42:51 PM
Sender Class Name: TApplication
Sender Name:
Current Work Directory: C:\Windows\system32
Exception Class Name: EAccessViolation
Exception Message: Access violation at address 0000000000647700 in module 'Launcher.exe'. Read of address 0000000000000018



Hope you can use this information.  If there is any other information I can provide, please let me know.

John
Tampa, Florida

*

Via Cassian

  • Newbie
  • *
  • 8
  • +0/-0
    • View Profile
Re: Shortcuts Lost When Saving
« Reply #12 on: February 13, 2013, 11:34:19 PM »
ooops, the dates in the above post should be January 2013.  It's late, sorry.

*

Webhelpforums

  • Administrator
  • Hero Member
  • *****
  • 1387
  • +6/-0
  • Shared between Microsys, WebHelpForums and helpers
    • View Profile
    • Webmaster and Website Help Forums
Re: Shortcuts Lost When Saving
« Reply #13 on: February 14, 2013, 06:30:34 AM »
I will see if I can use the error messages. Feel free to email me your existing shortcuts file!


If anyone ever can generate a project using shortcuts avilable on any Windows system and then duplicate the problem, I will, just brainstorming here, give a bounty price of some sort. (I would have to investigate how do that legally if it involced money.)

Did the shortcuts include anything networked? In the past (long ago), there was an issue if someone e.g. added a control panel shortcut (if I recall correctly) since Launcher did not know how to handle that. I solved that though (and also rewrote the saving process, so errors like that should not affect it), but if there is anything unsuaul with any of the shortcuts, that would have special interest :)


MicrosysTools.com | Website and SEO Software for webmasters | A1 Sitemap Generator, A1 Website Analyzer etc.

*

tKhomas

  • Newbie
  • *
  • 3
  • +0/-0
    • View Profile
Re: Shortcuts Lost When Saving
« Reply #14 on: February 14, 2013, 10:41:02 AM »
Hm, ok some more information:
- Windows Vista 64 bit
- I have only menu folders and standard short cuts, no network things. 5 folders, 6 subfolders.
- I also had a problem once with saving with an older version long ago, i don't remember details now. But since then, i managed shortcuts on 2 systems (Win XP the other one) and never had any problems.

*

Via Cassian

  • Newbie
  • *
  • 8
  • +0/-0
    • View Profile
Re: Shortcuts Lost When Saving
« Reply #15 on: February 14, 2013, 04:54:33 PM »
It happened again today as I was saving a Dir on Disk shortcut to a menu folder. I lost all but a couple of my shortcuts. 

No shortcuts are networked. 

The logs do not show any new information from what I posted earlier.

I will email you my shortcut files.

Thanks for working on this issue. 

John
Tampa


*

Webhelpforums

  • Administrator
  • Hero Member
  • *****
  • 1387
  • +6/-0
  • Shared between Microsys, WebHelpForums and helpers
    • View Profile
    • Webmaster and Website Help Forums
Re: Shortcuts Lost When Saving
« Reply #16 on: February 22, 2013, 03:14:26 PM »
There's a new betta available now at:
http://www.microsystools.com/products/launcher/all-versions.php

2.0.0 update #2

Besides some tweaks in saving, it includes much more logging. In truth, I may need to increase logging further, but I wanted to release a beta for those who wanted it :)
« Last Edit: February 22, 2013, 03:17:46 PM by Webhelpforums »
MicrosysTools.com | Website and SEO Software for webmasters | A1 Sitemap Generator, A1 Website Analyzer etc.

*

tKhomas

  • Newbie
  • *
  • 3
  • +0/-0
    • View Profile
Re: Shortcuts Lost When Saving
« Reply #17 on: August 25, 2013, 08:09:38 AM »
I wanted to change my shortcuts today, and decided to install the latest version first. Did this, download from the webpage.
Then i deleted one shortcut, and saved - with lost shortcuts again. I have uploaded the shortcuts folder before and after the change, and included my options.ini and program.log here:
http://www.fastshare.org/download/launcher_debug.zip

Then i used the automatic backup to restore my shortcuts, and did the exact same thing again (deleting the shortcut for TuneUp Utilities in the Tools folder) - and it worked. Good luck with solving that :(

Guess it will be extremely difficult to find an example with system shortcuts only for this behaviour, when it is not even the same after restoring the backup shortcuts.

regards,
Thomas

*

Webhelpforums

  • Administrator
  • Hero Member
  • *****
  • 1387
  • +6/-0
  • Shared between Microsys, WebHelpForums and helpers
    • View Profile
    • Webmaster and Website Help Forums
Re: Shortcuts Lost When Saving
« Reply #18 on: September 01, 2013, 07:02:48 AM »
Thanks for taking the time to report the issue.

You are correct that the problem has been extremely hard to track down and reproduce :(

If it was possible to create a configuration that would fail on each computer every time, problem had ben completely squashed immediately.
MicrosysTools.com | Website and SEO Software for webmasters | A1 Sitemap Generator, A1 Website Analyzer etc.

*

Webhelpforums

  • Administrator
  • Hero Member
  • *****
  • 1387
  • +6/-0
  • Shared between Microsys, WebHelpForums and helpers
    • View Profile
    • Webmaster and Website Help Forums
Re: Shortcuts Lost When Saving
« Reply #19 on: April 28, 2014, 07:55:15 AM »
Update: I believe this issue has been fully resolved in version 2.1
MicrosysTools.com | Website and SEO Software for webmasters | A1 Sitemap Generator, A1 Website Analyzer etc.

 




See Our Webmaster Tools for Windows and Mac

A1 Sitemap Generator
      
A1 Website Analyzer
      
A1 Keyword Research
      
A1 Website Download
      
A1 Website Search Engine
      
A1 Website Scraper